Install cvsup:
cd /usr/ports/net/cvsup-without-gui && make install
For Stable use tag=RELENG_4
Create file /usr/src/current-supfile with this inside:
Use this cvsup file:
# IMPORTANT: Change the next line to use one of the CVSup mirror sites
*default host=cvsup.dk.FreeBSD.org
*default base=/usr
*default prefix=/usr
*default release=cvs tag=.
*default delete use-rel-suffix
*default compress
src-all
Run cvs up
/usr/local/bin/cvsup -g -L 2 /usr/src/current-supfile
Compile new source
rm -rf /usr/obj/* <- deletes old objectfiles
cd /usr/src
make buildworld <- starts the compile
configure the kernel makefile
cd /usr/src/sys/
cp GENERIC MYKERNEL
edit mykernel to fit your configuration
compile kernel:
cd /usr/src
make buildkernel KERNCONF=MYKERNEL
install kernel:
make installkernel KERNCONF=MYKERNEL
reboot the machine, go into boot prompt and type: boot -singel now machine will boot into singelmode
fsck / <- run fsck on / mount -u / <- remont / rw mount -a -t ufs <- mount other unix file systems swapon -a <- activate swap install the souce we compiled before cd /usr/src make installworld Merge config files: (i almost never do this) /usr/sbin/mergemaster -a update sysinstall cd /usr/src/release/sysinstall make all install reboot into youre newly upgraded os: fastboot